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Beyond the Basics – Advanced Global Editing 
This tutorial covers two new global editing commands: Change Field and Force Text into Subfield. You’ll 
also be using some advanced features: “only when” to make a change only when a certain condition is 
present, and “get text” to copy text from elsewhere in the record. 

 

Import records 
If you did not import records in a previous tutorial, proceed with the following steps to import the practice 
records into your database. If you already imported records, skip to the next section. 

Import the tutorial records 
1. Open MARC Magician. 

2. Click File and then select Import. 

The Import box appears: 

 

Click the down-arrow  to the right of the Look in box, and select C:. In the area underneath the 
Look in box, double-click the Program Files folder, double-click the MARC Magician folder, and then 
click Tutorial Records.mrc. 

3. Click Import. 

The import starts. When it is finished, a summary box is displayed with the number of records imported 
and a count of the automatic cleanups that were done. 

In this tutorial you will learn how to: 

• Globally change a field. 
• Use the “only when” feature to make changes only when a certain 

condition is present. 
• Globally “force text” into a subfield. 
• Use the “get text” feature to copy text from another part of the record. 
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Changing a field & “only when” 

The scenario: Some of your video records have the words “VHS format” in the 500 (General Note) field. The 
proper field for this information is 538 (System Details). Because these records also contain other 500 fields 
that are correct, you cannot simply change all of the 500’s to 538’s – you’ll have to see to it that only the 
incorrect fields get changed. 

In this exercise, you’ll use the Change Field global editing command to fix these records. You’ll use the 
advanced “only when” feature to ensure that only the 500 notes that contain the words “VHS format” are 
changed. 

Select records with certain text 
The first thing you’ll do is select all of the records that have “VHS format” in the 500 (General Note) field. 

1. On the Select menu, click Records with Certain Text. 

The Select Records with Certain Text dialog box appears. Because we used this dialog box in the last 
tutorial, parts of it are filled in already. 

2. Under Fields to look in, click Clear Selected to clear the previous setting. 

3. Click the plus sign next to the Notes category to expand it, and then select 500 (Note: General), or 
type 500 in the Fields to search box. 

4. Under Text to find, in the Look for box, delete any existing text and type VHS format. 

 

5. Click Select. 

The records should now be selected in the Master List. Look at the status bar at the bottom of the main 
window to see how many are selected. 
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Add selected records to list 
Next you’ll add the records you just selected to a custom list. Although you don’t have to do this step 
before editing the records, creating a separate list will help you keep better track of these records following 
the global edit. 

1. On the List menu, point to Add Selected Records to List, and then click New. 

The New List dialog box appears. 

2. In the Name box, type a name for your list, and then click OK. 

A new list is created. It should contain the twelve records with “VHS format” in the 500 field. 

Change field 
Now you are ready to do the global edit. 

1. On the Select menu, click All Records. 

2. Click the Global Editing button  on the toolbar, and then click Change Field. 

The Change Field dialog box appears: 

 

3. Under Change Field, click Select to choose the field to change. 

The Select Field dialog box appears: 
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4. Click Select from text box, type 500 in the box, and then click OK. 

 

You return to the Change Field dialog box. Now you can select the field you want to change the 500 
into. 

5. Under Into field, click Select. 

The Select Field dialog box appears again. 

6. Select 538 (Note: System Details) or type 538 in the box, and then click OK. 

You return to the Change Field dialog box, which should now look like this: 

 

Next, you’ll restrict the change to only certain 500 fields by specifying the advanced “only when” 
criteria. 

7. Click Advanced. 

The Change Field dialog box expands to show the following: 

 

Right now, Always is displayed under Only when field meets these criteria. You don’t always want to 
change the 500 to a 538 – you only want to change it when it contains the words “VHS format,” so you 
have to change this setting. 
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8. Click Change to change the criteria. 

The Only when field meets criteria dialog box appears: 

9. Click Only when the following condition is met. 

Next you’ll select a specific subfield in the 500 field and specify what text it must contain in order for 
the field to be changed into a 538. 

10. Under Condition, select $a (General note). 

Next to that, you should see the word “Contains” displayed in the list. 

11. Type VHS format in the box as shown below. 

Your Only When box should look like so: 

 

12. Click OK to save your settings and return to Change Field. 

Your criteria should now be displayed under Advanced: 

 

You’re just about ready to begin the global edit! 

13. Review the settings in the Change Field dialog box, and then click OK. 
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The Make Change dialog box appears: 

 

This dialog box shows the first record. The field that will be changed is highlighted. At the bottom of 
the dialog box, you see what the field will be changed to. So far, so good. 

14. Click Change to change the field and continue with the global edit. 

The Make Change dialog box will appear for every potential change. Review the next three or four 
changes, clicking Change each time to make the change and move on. 

15. The command seems to be working as intended, so you can click Change All to complete the global 
edit without further prompting. 

When the program finishes editing, you see the Completed Change Field dialog box, which tells you how 
many changes were made. 

Review changes in the Record Viewer 
To be sure that the global edit worked properly, you’ll do a quick visual check of the records in the Record 
Viewer. 

1. All of the records in your list should still be selected, but if they’re not, open the Select menu and click 
All Records. 

2. Click the Record Viewer button   on the toolbar. 
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The Record Viewer appears in a new window: 

 

Check the first record. Does it have “VHS format” in the 538 field? So far, so good. 

3. Click Next to move to the next record. 

4. Quickly scan the rest of the records, and then click Done to close the Record Viewer. 

Delete the list 
Now that you’re really sure that the records have been properly cleaned up, there’s no need to keep them 
separate from the rest of the records in the Master List. You can delete the custom list you created. 

1. On the List menu, click Delete Whole List. 

The Delete Whole List dialog box appears. 

After all the work you’ve just done, you don’t want to completely delete the records – you want to 
leave them in the Master List. 

2. Click Keep them in the Master List (and other lists), and then click Delete List. 

3. Click Delete List again. 

Forcing subfield text & “get text” 

The Scenario: You downloaded some records from the Internet that have the classification number part of 
the call number in the 082 (Dewey Decimal Call Number) field. You want to copy this information into the 
proper holdings subfield so that it can be used by your library automation system. 

Rather than opening each record in the Cataloger and copying the call number by hand, you’ll use the 
Force Text into Subfield global editing command to “get” the information from the 082 field and put it into 
your holdings. 
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Here’s how Force Text into Subfield works: If the subfield you are forcing text into does not appear in the 
record, it is added with the text you specify. If the subfield you are forcing text into is in a field that is not 
already in the record, the field is added with the single subfield and the text you specify. If the subfield you 
are forcing text into is already in the record, the existing text is removed and replaced with the text you 
specify. If there is more than one of that subfield in a single field, duplicates are removed. 

 

Select records with an 082 field 
Before you begin global editing, you’ll select the records you want to work with – that is, just the records 
that have an 082 field. To do this, first you’ll select all of the records that don’t have this field, and then 
you’ll use the Invert Selection command to select only the records that do. 

1. On the Select menu, click Records with a Missing Field or Subfield. 

The Select Records with a Missing Field or Subfield dialog box appears: 

 

2. Click Other, and then click Change. 

Note: 

Force Text into Subfield is the best global editing command for adding holdings 
information, because it adds the information to the existing holdings rather than 
adding a new one. It only adds a new holding when none exists already. 
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The Other Missing Fields dialog box appears: 

 

3. Click Select from text box, type 082 in the box, and then click OK. 

You return to the previous text box. 

4. Click OK. 

The dialog box closes and the records that are missing the 082 field are selected in the Master List. 

5. On the Select menu, click Invert Selection. 

Now only the records that have the 082 field are selected in the Master List, and you are ready to begin 
global editing. 

Force text into subfield 

1. Click the Global Editing button  on the toolbar, and then click Force Text into Subfield. 

The Force Text into Subfield dialog box appears: 

 

First you have to select the holdings subfield into which you’ll copy the information from the 082. 

2. Click Select. 



MARC Magician Tutorial 8 – Advanced Global Editing 11 

The Select Subfield dialog box appears: 

 

What you do next depends on your holdings type: 

3. If you use Easy Entry holdings, click the plus sign next to the Holdings category, and then select the 
holdings element as follows: 

With this holdings type...  Choose... 

Alexandria V Title Call # 

Athena  Call no. - Main 

Dynix Call number 

Follett Catalog Plus Call number 

Library Pro Circ call 

LibraryWorld Circ call 

Winnebago Spectrum CIRC/CAT Local call number 

852 with 4 part call number  Classification number 

852 with 1 part call number Call number 

4. If you use Custom holdings, click Select from text box, and then type the holdings field tag and the 
subfield code that you use for the call number (or classification number) in the box. 

5. Click OK to return to the Force Text into Subfield dialog box. 

The holdings element or subfield you selected should now be displayed under Subfield to force. 
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Get text 
The next step is to specify what text you want to force into the subfield you just selected. In this scenario, 
you want the information to come from subfield 082 a, so you will use the “get text” feature to copy the 
text from this subfield. 

1. Put the insertion point in the white box under Text to force into subfield by clicking anywhere in the 
box. 

2. Click Get Text. 

The Get Text dialog box appears: 

 

3. Click Select. 

The Select Subfield dialog box appears. 

4. Click Select from text box, type 082a in the box, and then click OK to return to the Get Text dialog 
box. 

5. Click OK again to return to the Force Text into Subfield dialog box. 

Under Text to force into subfield, you should now see the following: 

 

6. Click OK to begin global editing. 
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As with other global editing commands, the Make Change dialog box appears, giving you the chance 
to review each potential change before it is made: 

 

7. The first one looks fine, so click Change to make the change and continue to the next record. 

As always, you should check the first few changes to make sure that everything is working properly. 
After reviewing three or four records, click Change All to make the change in all of the selected 
records, without further prompting. 

When the program is finished editing the records, the Completed Force Text into Subfield box appears, 
showing you how many changes were made. 

Review changes in the Record Viewer 
The records should still be selected in the Master List. If you like, you can review the changes as you did in 
the first exercise: 

1. Click the Record Viewer button  on the toolbar. 

In the Record Viewer, holdings data appears near the bottom of each record. (If you do not see any 
holdings, click Options. The Options dialog box appears with the View tab in front. Under Record 
viewer, make sure the Show holdings check box is selected.) 

2. When you are finished checking the records, click Done to close the Record Viewer. 
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Review & practice 
Congratulations! You just completed the last tutorial. Hope you enjoyed yourself. 

Now you can take a break, practice some more on your own, or get to work on your own records. 

Take a break 
If you’d like to take a break, on the File menu, click Exit. 

Practice some more 
Here are some suggestions for practicing on your own: 

• Try some other global editing commands such as Change Control Field Value, Delete Fields, and 
Change Subfield. Can you think of a scenario where these would be useful in your library? 

• Use the “only when” and “get text” features in different contexts. 

• As always, refer to Help when you have questions. 

Get to work on your own records 
If you feel like you don’t need any more practice and want to get to work on your own records, you just 
need to delete the practice records and you’re ready to go: 

1. Click Select, and then click All Records. 

2. Click Record, and then click Delete from All Lists. 

The Master List should now be empty.  
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