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Getting Organized – Working with Record Lists 

 

Import records 
The first step in working with this tutorial is to import records into MARC Magician.  

Import the tutorial records 
1. Open MARC Magician. 

2. Click File and then select Import. 

The Import box appears: 

 

Click the down-arrow  to the right of the Look in box, and select C:. In the area underneath the 
Look in box, double-click the Program Files folder, double-click the MARC Magician folder, and then 
click Tutorial Records.mrc. 

3. Click Import. 

The import starts. When it is finished, a summary box is displayed with the number of records imported 
and a count of the automatic cleanups that were done. 

In this tutorial you will learn how to: 

• Import records. 
• Sort records. 
• Find specific records in the list. 
• Move and resize record list columns. 
• Show and hide record list columns. 
• Select records. 
• Delete records and restore deleted records. 
• Create your own record lists. 
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Sorting records 
The quickest way to sort the record list is to click the column header of the column you want to sort by. You 
can reverse the sort order by clicking it again. 

Sort by title 
• Click the Title column header. 

The records should now be sorted alphabetically by title. Notice that the current sort order is displayed on 
the status bar at the bottom of the window: 

 

 

Moving and resizing columns 
In this lesson you’ll change the look of record lists by rearranging columns and changing their size. 

Move a column 
Because there are too many columns to display all at once on your screen, you may want to change the 
order in which the columns appear, so that the ones you use the most are always visible. You change the 
column order by dragging the column headers with the mouse. 

  

Before: Author column before Title column After: Title column before Author column 

1. Point to the Title column header with your mouse. 

2. Press the mouse button and hold it down. 

3. While holding down the mouse button, drag the Title column header to the left of the Author column 
header. 

4. Release the mouse button. 

Resize a column 
You can change the width of record list columns. For example, if a column is too narrow to show all of the 
text in it, you can make the column wider. If the column is wider than it needs to be, you can make it 
narrower so that more columns fit on your screen. 

Note: 

Some records may have multiple entries in the bar code, call number, and subject columns. For 
example, most records have two or more subject headings, so the Subject column usually displays 
several entries for each record. For this reason, when you sort the records by subject, records with 
multiple subject headings will appear more than once in the list. 
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 split line 

 

1. Point to the split line to the right of the Title column header. 

2. When the pointer becomes a |, hold down the mouse button and drag the mouse to the right. 

3. When the column is the size you want, release the mouse button. 

Showing and hiding columns 
Another way to customize lists is to hide the columns that you don’t need. In this exercise you’ll hide some 
columns in the Master List. 

1. On the List menu, click Show/Hide Columns. 

The Show/Hide Columns dialog box appears: 

 
 
This dialog box shows all of the possible columns. 

2. Clear the check boxes for Bar Code, Created By, Export Date, Import Batch, Import Date, Import 
Repairs, Imported By, Update Date, and Updated By as shown in the figure above. 

3. Click OK to close the dialog box and save your changes. 

The Master List now shows only the columns you selected. You can show the columns again at any 
time by opening the Show/Hide Columns dialog box again and selecting the columns you want. 
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Finding records 
You use the Find command to locate a specific record in the list. This is particularly useful when you have a 
lot of records in your database. In this exercise you’ll find the record titled Almayer’s Folly and Other Stories 
by Joseph Conrad. 

Find a record 
1. Click the Find button on the toolbar. 

The Find dialog box appears: 

 

2. In the Find what box, type Conrad. 

You can choose whether the program should find the word if it appears anywhere in a column, or only 
if it appears at the beginning. 

3. Under Search Criteria, click Contains. 

The Columns to Search list contains all of the columns in the record list. This allows you to narrow the 
search. If, for example, you only want to find books written by Conrad, but not books about Conrad, 
you could limit the search to the Author column. That’s what you’ll do now. 

4. Select the Author column, and then click Find Next. 

The program finds the record and outlines it in the list. It also scrolls to the column in which the text 
was found. 

Note that the record is outlined – not selected. You’ll learn how to select records in the next exercise. 
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Selecting records 
In this exercise you’ll learn several different ways to select records. 

In MARC Magician, knowing how to select records is very important, because before you can perform any 
operation on the records (like global editing, exporting, or printing), you have to select the records you 
want to work with. When you select a record, it appears highlighted in the record list. 

 

 

Select a single record 
First you’ll select just one record in the list. 

• Click a record. 

The record should now be highlighted. 

• Now click a different record. 

Notice that the first record you selected is no longer highlighted. 

Select several non-consecutive records 
Next, you’ll select several records that don’t appear next to each other in the list. 

1. Click a record that you want to select. 

2. Press the Ctrl key and hold it down. 

3. One by one, click each additional record you want to select. 

Note: 

It is very easy to remove a selection (or “deselect” records): just click somewhere 
else in the list. The record you click on will be selected, but all other records that 
were previously selected will no longer be selected. You can deselect a single 
record by clicking it while holding down the Ctrl key. 
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(If you accidentally click a record you don’t want, click it again to deselect it.) 

4. Release the Ctrl key. 

The records you selected should appear highlighted. 

Select a block of consecutive records 
Now you’ll select several records that appear next to each other in the list. 

1. Click the first record in the block. 

2. Press the Shift key and hold it down.  

3. Click the last record in the block.  

4. Release the Shift key. 

The block of records you selected should appear highlighted. 

Select all records 
Next you’ll select all of the records in the list. 

• On the Select menu, click All Records. 

 

Select records that contain a certain word or phrase 
You can also select records using the commands on the Select menu. These commands enable you to 
select records based on whether they fulfill certain criteria. 

Whenever you use these commands to select records, any previous selection is removed. Only the records 
that meet the criteria you specify are selected. 

In this example you’ll use the Records with Certain Text command to select records that contain a word or 
phrase that you specify. 

1. On the Select menu, click Records with Certain Text. 

Tip: 

Here’s a quick way to select all records by using a keyboard shortcut: Press the 
Ctrl key and hold it down. Press the A key, and then release the Ctrl key. 
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The Select Records with Certain Text dialog box appears: 

  

Under Fields to look in, you can choose whether the program should search the whole record or only 
certain fields or subfields. In this example, you’ll search the whole record. 

2. Click All 

3. Under Text to find, in the Look for box, type Brown.  

 

 

4. Click Select to begin searching. 

The program selects all records that contain the word “Brown” – in this case, just one. The status bar 
shows how many records are currently selected. 

 

Note: 

If you select the Match case check box, the program will only search for text that is 
capitalized exactly as you typed it in the Look for box. 

If you select the Whole words only check box, the program will only search for the whole 
word you typed (that is, if you type “monster” the program won’t find “monsters”). 
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Deleting records 
When you delete a record from the Master List, it goes into the Weeding Truck. The Weeding Truck is 
analogous to the Microsoft Windows Recycle Bin. If you decide to keep the record after all, you can restore 
it to the Master List. Once you empty the Weeding Truck, however, the records it contained are gone 
permanently. 

Delete a few records 
1. Select a couple of records in the Master List. 

2. On the Record menu, click Delete from All Lists. 

The selected records should disappear from the Master List. They are moved to the Weeding Truck, 
where they will remain until you delete them permanently by emptying the Weeding Truck. 

 

Restoring deleted records 
If you decide that you want to keep the records you deleted after all, you can restore them to the Master 
List. 

Restore the records you deleted 
1. On the Window menu, click Weeding Truck. 

The Weeding Truck appears in the foreground and becomes the active list. 

2. On the Edit menu, click Select All. 

3. On the Record menu, click Move to Master List. 

The records should disappear from the Weeding Truck. Now switch back to the Master List: 

4. On the Window menu, click Master List. 

You should now see the records in the Master List again. 

What are custom lists? 
Custom lists are lists that you create in order to organize records into groups. This separates them out from 
the crowd, making it easier to carry out global editing tasks or export them in a single batch. 

Custom lists contain a subset of the records in the Master List. Every record in a custom list is also always in 
the Master List. If you edit a record in a custom list, the changes to the record are reflected in the Master 
List (and any other custom lists that contain the record). 

You can create as many custom lists as you wish, and, unlike the Master List and the Weeding Truck, you 
can delete and rename custom lists. 

Tip: 

Here’s a convenient way to delete records using a keyboard shortcut: Select the records you want to 
delete. Press the Ctrl key and hold it down. Press the Delete key, and then release the Ctrl key. 



MARC Magician Tutorial 4 – Working with Lists 10 

Creating custom lists 
There are a couple of ways to go about creating a new list. You can first create an empty list, and then add 
records to it, or you can select the records you want in the list first, and then add them to a new list. 

In this exercise you’ll use the latter method to create a list for all your video recordings. You also get a 
chance to use a different command on the Select menu. 

Select the records for your list  
First you’ll select all of the video recordings. 

1. On the Select menu, click Records that Use a Certain Template. 

The Select Records that Use a Certain Template dialog box appears: 

 

2. Click the Videorecording - VHS or Beta template, and then click Select. 

All of the videocassettes should now be selected. 

Add the records to a new list 
Now you’ll create a new list containing just the selected records. 

1. On the List menu, point to Add Selected Records to List, and then click New. 
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The New List dialog box appears: 

 

2. Type a name for your list, and then click OK. 

The videocassettes are added to the new list. The new list appears in a separate window inside the 
main window. The name of the list appears on the title bar. 

Remove records from your list 
Now you’ll take some of the records out of your list. 

• Select a record or two, and press Delete. 

The records are removed from your list, but they remain in the Master List. 

 

Delete your list 
The last thing you’ll do is delete the list you just created. 

1. On the List menu, click Delete Whole List. 

The following dialog box appears: 

 

When you delete a list, you have to decide what to do with the records in it. You can leave them in the 
Master List, or delete them from all lists and move them to the Weeding Truck. 

2. Click Keep them in the Master List (and other lists), and then click Delete List. 

A message will appear at the bottom of the dialog box asking whether you’re quite, quite sure. 

Tip: 

To delete records from all lists (i.e., move them to the Weeding Truck), press the 
Ctrl key and hold it down. Press the Delete key, and then release the Ctrl key. 
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3. Click Delete List again. 

Your list disappears, and the Master List is your list. 

Review & practice 
It’s fair to say you’ve learned a heck of a lot in this tutorial. You now know how to “redecorate” in the main 
window by moving and resizing columns. You can locate, sort, and select records, and you know how to 
manage and group records with custom lists. 
 

Now you can take a break, practice some more on your own, go right on to the next tutorial, or get to work 
on your own records. 

Take a break 
If you’d like to take a break, on the File menu, click Exit. 

Practice some more 
Here are some suggestions for practicing on your own: 

• Practice selecting records using the mouse together with the Shift and Ctrl keys. 
• Try out some of the other commands on the Select menu. 
• Explore the other commands on the List menu. 
• Create some more custom lists and practice adding and removing records. 
• As always, refer to Help when you have questions. 

Go to the next tutorial 
If you’d like to jump right in to the next tutorial, stay where you are in the main window. You’re all set to 
begin the next tutorial. Remember that you can do most of the tutorials in any order you’d like. 

Get to work on your own records 
If you feel like you don’t need any more practice and want to get to work on your own records, you just 
need to delete the practice records and you’re ready to go: 

1. Click Select, and then click All Records. 

2. Click Record, and then click Delete from All Lists. 

The Master List should now be empty.  
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